Home > EIGRP GNS3 Lab

EIGRP GNS3 Lab

December 3rd, 2010 Go to comments

In this tutorial we will learn how to use EIGRP to run a small network with 5 routers. Below is the topology of this lab

EIGRP_4routers_topology.jpg

This lab consists of 5 routers and we need to configure EIGRP among them. It is done when we can successfully ping among R2, R3, R4 & R5 and the routing tables of these routers show that they are running EIGRP (with letter “D”).

IOS used in this tutorial: c2600-bin-mz.123-6f.bin (with a minimum of 64 MB RAM) but you can use other IOS.

Note: If you are not sure about EIGRP, please read my EIGRP Routing Protocol tutorial first

IP addresses of routers:

+ R1:
s0/0 – 192.168.30.12/28
s0/1 – 192.168.30.18/28
s0/2 – 192.168.30.35/28
f0/0 – 192.168.60.10/28

+ R2:
s0/0 – 192.168.30.13/28

+ R3:
f0/0 – 192.168.60.13/28

+ R4:
s0/0 – 192.168.30.20/28

+ R5:
s0/0 – 192.168.30.40/28

If you are not sure about EIGRP, please read my article about this routing protocol at http://www.autismtoday.com/?page=eigrp-routing-protocol

Some important notes about EIGRP:

+ All routers must use the same Autonomous System (AS) number to recognize each other. In this case the chosen AS is 100.
+ The major network in this lab is 192.168.30.0 & 192.168.60.0 so there will be discontiguous networks -> need to use the “no auto-summary” command.

Now let’s begin the lab!

Step 1 – Configuring IP addresses on the routers

*On R1:
R1#config t
R1(config)#int s0/0
R1(config-if)#ip address 192.168.30.12 255.255.255.240
R1(config-if)#no shut
R1(config-if)#int s0/1
R1(config-if)#ip address 192.168.30.18 255.255.255.240
R1(config-if)#no shut
R1(config-if)#int s0/2
R1(config-if)#ip address 192.168.30.35 255.255.255.240
R1(config-if)#no shut
R1(config-if)#int f0/0
R1(config-if)#ip address 192.168.60.10 255.255.255.240
R1(config-if)#no shut

*On R2:
R2#config t
R2(config)#int s0/0
R2(config-if)#ip address 192.168.30.13 255.255.255.240
R2(config-if)#no shut

*On R3:
R3#config t
R3(config)#int f0/0
R3(config-if)#ip address 192.168.60.13 255.255.255.240
R3(config-if)#no shut

*On R4:
R4#config t
R4(config)#int s0/0
R4(config-if)#ip address 192.168.30.20 255.255.255.240
R4(config-if)#no shut

*On R5:
R5#config t
R5(config)#int s0/0
R5(config-if)#ip address 192.168.30.40 255.255.255.240
R5(config-if)#no shut

Now all the interfaces are up. We should check the interfaces on R1 to confirm this with the “show ip int brief” command

EIGRP_4routers_topology_R1_show_ip_int_brief_before.jpg

Notice that all both the “Status” and “Protocol” of the connected interfaces were up.

We can see all the neighbors of R1 with the “show cdp neighbors” command on R1:

EIGRP_4routers_topology_R1_show_cdp_neighbors_before.jpg

At this time we can ping between two directly connected interfaces. For example a ping from s0/0 of R1 to s0/0 of R2 (192.168.30.13) will be successful.

EIGRP_4routers_topology_R1_ping_test1.jpg

but a ping between two far-away interfaces is not successful. For example a ping from R2 to s0/0 of R4 (192.168.30.20) will be unsuccessful.

EIGRP_4routers_topology_R1_ping_test2.jpg

If we use the “show ip route” on these routers we will only see directly connected link.

Step 2 – Enable EIGRP on all the routers

*On R1
R1(config)#router eigrp 100
R1(config-router)#network 192.168.30.0
R1(config-router)#network 192.168.60.0
R1(config-router)#no auto-summary

*On R2
R2(config)#router eigrp 100
R2(config-router)#network 192.168.30.0
R2(config-router)#no auto-summary

*On R3
R3(config)#router eigrp 100
R3(config-router)#network 192.168.60.0
R3(config-router)#no auto-summary

*On R4
R4(config)#router eigrp 100
R4(config-router)#network 192.168.30.0
R4(config-router)#no auto-summary

*On R5
R5(config)#router eigrp 100
R5(config-router)#network 192.168.30.0
R5(config-router)#no auto-summary

After typing above commands we will see the neighbors adjacency on these routers are up. For example on R1 we will see

EIGRP_4routers_topology_R1_EIGRP_neighbors_up.jpg

Now the EIGRP process is up and we can ping from anywhere. For example a ping from R2 to s0/0 of R4 (192.168.30.20) will be successful now.

EIGRP_4routers_topology_R2_ping_test_after_1.jpg

By checking the routing table of R2, R3, R4 & R5 we can confirm EIGRP has been implemented successfully. For example, using the “show ip route” command on R5 we see

EIGRP_4routers_topology_R5_ip_route_after.jpg

Notice that the routes to 192.168.30.16 & 192.168.60.0 are marked with a letter “D”, meaning it is learned via EIGRP. Maybe you are wondering “why is the letter “D” used for EIGRP, not “E”? Well, the answer is the letter “E” has been “stolen” for EGP – an external routing protocol – but it is not popular nowadays :)

We can check the neighbor relationships on these routers with the “show ip eigrp neighbors” command. Below is an example of R1:

EIGRP_4routers_R1_show_ip_eigrp_neighbors_after.jpg

To see the topologies of these routers, use the “show ip eigrp topology” command. Below is the output of R4

EIGRP_4routers_topology_R4_show_ip_eigrp_topology.jpg

Download the configured network

TROUBLESHOOTING part

In this part, we created a faulty network and your task is to find out and fix the errors to make the network run perfectly. You can download the files here: Download faulty network

Comments (23) Comments
Comment pages
1 2 363
  1. jokerdc
    April 10th, 2014

    it works simply because there are not discontiguos network…. the networks pass trought R1 that handles both 192.168.30.x and 192.168.60.x classes

  2. kim
    July 24th, 2014

    there should be a clock rate configured to router 1? am i right?

  3. Doug
    October 25th, 2014

    Great Lab – Thanks!

  4. adnan
    January 26th, 2015

    Send latest dumps at adnan1.faisal@gmail.com

  5. Nihal Jain
    February 7th, 2015

    How do I open the faulty network .cfg file?

  6. Morgen
    February 23rd, 2015

    I am new to GNS3 … want to ask .. Do I have to add switch image like I did in router case …

  7. Anonymous
    April 24th, 2015

    can anyone help me, i need to study ccna (803) can anyone help me with latest dumps, or VCE simulator please, my email adres is andersondchikati@gmail.com. many thanks

  8. Anonymous
    July 1st, 2015

    kjhwsjkfjkads;llkdsag

  9. Anonymous
    July 5th, 2015

    I also get this error message

    *** Error: 209-unable to start VM instance ‘ghost-c2600-bin-mz.123-6f.bin-localhost.ghost’
    How to open this net file?

  10. Ashraf
    October 3rd, 2015

    I also need CCNA dumps kindly send me the same , Thank you

  11. erio
    January 26th, 2016

    Hello friend..
    Please Send me the latest CCNA dumps. Thank You.
    Email Add: {email not allowed}

  12. SKYE
    January 28th, 2016

    what is the classful routing?

  13. SKYE
    January 28th, 2016

    what is the commands?

    Thanks :)

  14. recardoandy
    April 21st, 2016

    good lab and explain

  15. pr4dn3sh
    May 5th, 2016

    when i configure these networks on packet tracer. after configuring and assigning all the ip addresses, my f0/0 status is up but protocol status is down, can anyone help me out with?
    thank you!

  16. faufao
    May 26th, 2016

    i can see r2 r4 and r5 when i use cdp neighbors. however im not seeing r3? also, i am not able to ping from r1 to r4 and r5. only in r2. please help

  17. friemds m naaz please help me
    June 1st, 2016

    I want dumps of CCNP with practicals
    My email id : {email not allowed}
    Thnx

  18. Anonymous
    June 7th, 2016
  19. Mayen
    June 7th, 2016
  20. AZIZ
    September 6th, 2016

    great lab _thank you

  21. additional reading
    December 29th, 2016

    Really intriguing elements you have remarked, thanks so much for submitting.

    http://www.takanon.org

  22. Mozelle Buttermore
    February 20th, 2017

    I just want to tell you that I am newbie to weblog and actually liked this web blog. Almost certainly I’m going to bookmark your blog . You amazingly have fantastic well written articles. Thanks for sharing with us your website page.

    http://articles.org/EFBBBFmaster-universitario-de-fisioterapia-en-el-deporte-2/

  23. Yo
    March 17th, 2017

    I downloaded the Faulty network files, how do I open it?

Comment pages
1 2 363