Home > Frame Relay – GNS3 Lab

Frame Relay – GNS3 Lab

July 30th, 2011 Go to comments

In this article we will create a Frame Relay in GNS3 to learn how to configure Frame-Relay.

Note: If you need to revise your Frame Relay knowledge, we recommend you to read our Frame Relay tutorial first.

First we create 4 routers and link them as follows:

Frame_Relay_Topology.jpg

IOS used in this lab: c2600-bin-mz.123-6f.bin

Configure IP addresses

First we will assign IP addresses for all relevant interfaces. Notice that R1 will be Frame-Relay switch in this lab so its interfaces don’t need IP addresses.

On R0:

R0#configure terminal
R0(config)#interface s0/0
R0(config-if)#ip address 192.168.1.1 255.255.255.0
R0(config-if)#no shutdown

On R2:

R2#configure terminal
R2(config)#interface s0/0
R2(config-if)#ip address 192.168.1.2 255.255.255.0
R2(config-if)#no shutdown

On R3:

R3#configure terminal
R3(config)#interface s0/0
R3(config-if)#ip address 192.168.1.3 255.255.255.0
R3(config-if)#no shutdown

Configure Frame-Relay (using Inverse ARP)

To configure Frame-Relay on R0, R2 and R3 we need to enable Frame-Relay encapsulation and specify a type of LMI (ansi – in this case). Notice that Inverse ARP is enabled by default on Cisco routers so we don’t need to type anything to activate it.

R0,R2,R3(config)#interface s0/0
R0,R2,R3(config-if)#encapsulation frame-relay
R0,R2,R3(config-if)#frame-relay lmi-type ansi

Configure R1 as a Frame-Relay switch

In this lab R1 will be configured as a Frame-relay switch so no IP address is required.

Turn on Frame-Relay switching feature on R1:
R1(config)#frame-relay switching

On each interface we must specify how the frame will be proceeded. In practical, the Frame-Relay switch (R1) is placed at the ISP side so its interfaces should be set to DCE.

R1(config)# interface s0/0
R1(config-if)#encapsulation frame-relay
R1(config-if)#frame-relay lmi-type ansi
R1(config-if)#frame-relay intf-type dce
//This command specifies the interface to handle LMI like a Frame Relay DCE device.
R1(config-if)#clock rate 64000
R1(config-if)#frame-relay route 102 interface Serial0/1 201
(will be explained later)
R1(config-if)#frame-relay route 103 interface Serial0/2 301

The command frame-relay route 102 interface Serial0/1 201 means frame-relay traffic come to R1 which has a DLCI of 102 will be sent to interface Serial0/1 with a DLCI of 201.

Note: Data link connection identifiers (DLCIs) are numbers that refer to paths through the Frame Relay network. They are only locally significant.

Continue configuring s0/1 & s0/2 interfaces (same as s0/0)

R1(config)# interface s0/1
R1(config-if)#encapsulation frame-relay
R1(config-if)#frame-relay lmi-type ansi
R1(config-if)#frame-relay intf-type dce
R1(config-if)#clock rate 64000
R1(config-if)#frame-relay route 201 interface Serial0/0 102

R1(config)# interface s0/2
R1(config-if)#encapsulation frame-relay
R1(config-if)#frame-relay lmi-type ansi
R1(config-if)#frame-relay intf-type dce
R1(config-if)#clock rate 64000
R1(config-if)#frame-relay route 301 interface Serial0/0 103

Use the show frame-relay map command to display the current map entries for static and dynamic routes

R0#show frame-relay map

Frame_Relay_R0_show_frame-relay_map.jpg

By default, Cisco uses Inverse ARP to map remote IP address of the PVC with the DLCI of the local interface as we can see here. From the output above we learn that DLCI 102 is set on Serial0/0 of R0 and mapped with 192.168.1.2. The status of this connection is “dynamic” and “active”, which means it is operating correctly.

The outputs of this command on other routers are shown below:

Frame_Relay_R2_show_frame-relay_map.jpg

Frame_Relay_R3_show_frame-relay_map.jpg

Notice that you will only see the “map” at two ends. If we issue this command on Frame-Relay switch (R1 is this case) it will show nothing.

The show frame-relay pvc command is used to display the status of all configured connections, traffic statistics, BECN and FECN packets received by the router.

Frame_Relay_R0_show_frame-relay_pvc.jpg

Frame_Relay_R1_show_frame-relay_pvc_1.jpg

Frame_Relay_R1_show_frame-relay_pvc_2.jpg

Frame_Relay_R2_show_frame-relay_pvc.jpg

Frame_Relay_R3_show_frame-relay_pvc.jpg

Use the show frame-relay lmi to display LMI traffic statistics (including LMI type, status messages sent and invalid LMI messages)

Frame_Relay_R0_show_frame-relay_lmi.jpg

Frame_Relay_R1_show_frame-relay_lmi.jpg

Frame_Relay_R2_show_frame-relay_lmi.jpg

Frame_Relay_R3_show_frame-relay_lmi.jpg

Pings from R0 to R2 & R3 are successful.

Frame_Relay_R0_ping_R2.jpg

Frame_Relay_R0_ping_R3.jpg

However ping from R2 to R3 is unsuccessful. It means that customers cannot see each other. This is because the split horizon rule: “A router never sends information about a route back in same direction which is original information came”. To overcome this problem we can configure subinterfaces on R0.

Frame_Relay_R2_ping_R3.jpg

Comments (32) Comments
Comment pages
1 2 3 775
  1. kd
    November 10th, 2014

    Where to get IOS image for this lab?

  2. Jake
    February 10th, 2015

    is there any simulation program available. if so, please send to jake@jake.co.kr

  3. Ruhul Amin
    February 10th, 2015

    hi I can’t see the rest of this lab, specially solution for @To overcome this problem we can configure subinterfaces on R0.@ how ?????

    in addition do we have lab for staitc

    please advise !

  4. Donna
    February 15th, 2015

    do any one have PDF of jermy lab ICND1 review complete ?

  5. Zecaspider
    March 14th, 2015

    Good stuff!
    Thanks guys

  6. kingsley
    March 18th, 2015

    bug its a point to multipoint connection. pls paste point to point connection

  7. davesupreme
    May 22nd, 2015

    same as Ruhul…. sub-interface config?….. been wanting to do this, finally got 4 T-1’s on my 2811 so i could do this one?…. any help would be appreciated!….

  8. Jawwad
    August 21st, 2015

    sorry I forgot to mention I need dumps for CCNA (200-120)

  9. Anonymous
    September 17th, 2015

    well appreciated, In need of latest dumps 200-120, email at ruwanthanrs@yahoo.com

  10. Ashley
    October 28th, 2015

    please could anyone send me the latest dumps 200-120. Email at aikinsashley@ymail.com

  11. G24
    November 6th, 2015

    Hey guys either anyone who loves to help people…..
    send me latest dump coz im planning to take the exam

  12. ahmed
    November 16th, 2015

    hey 9tut i have tried to configure the above topology for frme relay but i get an error when i try to use

    frme-relay switch command, the switch show an error i.e

    R3(config)#frame-relay switching
    ^
    % Invalid input detected at ‘^’ marker.

    please why i get that error and i want my switch to act as frame relay switch, and im using cisco packet tracer. thanks

  13. ahmed
    November 19th, 2015

    hey 9tut , i have done th the switching frame topology with gns3 and its working thanks.

  14. Q4E
    November 27th, 2015

    for those who tried simulating this exercise in gns3 but can’t run try using these commands: (using IOU images)

    Configure router (0/2/3) using these commands:
    -router rip
    -network 192.168.1.0
    -encapsulation frame relay
    -no shut
    (dont need to change LMI since “cisco” is used as default)

    Configure serial(0/0)(0/1)(0/2) of (router1) using these commands:
    -frame relay switching *enables switching feature of routers
    -encapsulation frame-relay
    -frame relay intf-type dce *since dce is needed for serial of frame relay switch
    -frame relay route 102 interface s0/1 201 *router 1 router 2
    -frame relay route 103 interface s0/2 301 *router 1 router 3

    *only one frame relay route should be used in interfacing s0/1 and s0/2

    hope this helps. and please correct me if somethings wrong. thanks!

  15. Maan
    February 22nd, 2016

    It is working for me.

  16. abeymax
    February 23rd, 2016

    Pass your final IT exam through vce dumps http://vcedownloads.com

  17. salem
    February 24th, 2016

    @abeymax, http://vcedownloads.com is for premium dumps -_-

  18. Anonymous
    March 24th, 2016

    Hello,
    I need CCNA dumps as I would be giving it in May 2016.
    My email ID is {email not allowed}
    Thank you!

  19. Geeta
    March 24th, 2016

    Hello,
    I need CCNA dumps as I would be giving it in May 2016.
    My email ID is {email not allowed}
    Thank you!

  20. Rain
    April 21st, 2016

    Hi, I need latest CCNA dumps(200-120).my email id {email not allowed}

  21. Anonymous
    June 5th, 2016

    could any one please send to me CCNA dump at mahmoudhamid101@GMAIL

  22. Fancy
    June 9th, 2016

    Dear all 9tut

    who have GSN3 study guile. please share !

  23. Buhle
    June 22nd, 2016

    hi guy anyone has ccna 120 dump pdf, please send to me at {email not allowed}

  24. Tho
    June 24th, 2016

    Can someone please send me a CCNA dump @ nhibaonguyen@yahoo Thanks so much.

  25. vinay
    July 5th, 2016

    Hi , I need latest CCNA dumps(200-120 ) . please send to me at {email not allowed}
    after two days I have an exam

  26. Anonymous
    July 30th, 2016

    hi guys planning to write exams july 30 2016

  27. otherguy
    August 17th, 2016

    took 200-102 today … a looot of Q on Frame Relay. Had 47q and 2sims, both on FR. Also a huge part on STP/RSTP — 3q on EIGRP and 4 or 5 on OSPF only :/ probably get set of questions due to new ccna / icnd2, so “old” guys have time to recertify :D

  28. AOT
    August 23rd, 2016

    hi guys, please I need the new CCNA Dumps, please email me syndy005(yahoo.com) I will be writing next 2weeks

  29. cccnaguy
    January 10th, 2017

    after configuration of R0 in this SIM I do not get any output when typing SHOW FRAME -RELAY MAP .
    any idea whats wrong ?????????? “show frame-relay pvc/route/lmi ” is working !!

  30. cccnaguy
    January 10th, 2017

    I mean R1 instead of R0 on last question !!!

  31. cccnaguy
    January 10th, 2017

    i got it … now working… :-) , should type on R0, R2 & R3 !! small details , very important !!

  32. Billye
    January 10th, 2017

    glee season 4 mp3 – myfreemp3.review/search/glee-season-4-mp3/
    download free music

Comment pages
1 2 3 775